GoPro liggur niðri
Incident Report for University of Akureyri
Resolved
Bilun hjá þjónustuaðila sem er búið að leysa
Posted Sep 14, 2023 - 14:48 UTC
Investigating
We are currently investigating this issue.
Posted Sep 14, 2023 - 08:50 UTC
This incident affected: GoPro (hýst hjá Hugvit).