VPN í ólagi

Incident Report for University of Akureyri

Resolved

This incident has been resolved.
Posted Oct 17, 2023 - 14:06 UTC

Update

We are continuing to investigate this issue.
Posted Oct 17, 2023 - 14:06 UTC

Investigating

We are currently investigating this issue.
Posted Oct 17, 2023 - 11:54 UTC
This incident affected: VPN.