Hægagangur á hjalp.unak.is
Incident Report for University of Akureyri
Resolved
This incident has been resolved.
Posted Feb 29, 2024 - 10:30 UTC
Investigating
We are currently investigating this issue.
Posted Feb 28, 2024 - 14:12 UTC
This incident affected: Jira Helpdesk (hýst hjá Atlassian).