Bilun í kerfum HÍ og Uglan úti
Incident Report for University of Akureyri
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 08:28 UTC
Investigating
We are currently investigating this issue.
Posted Mar 08, 2024 - 08:21 UTC
This incident affected: Ugla (hýst hjá HÍ).